File Uploads Encountering Intermittent Issues

Incident Report for Korbyt

Postmortem

Root Cause Analysis – CMS Upload Degradation

May 13, 2026

At 8:22 AM ET, automated alerting flagged unhealthy upload behavior in the production CMS. Initial investigation led to a server reboot; however, uploads continued to fail through 9:14 AM. The root cause was traced to an out-of-memory (OOM) condition on the upload endpoint, triggered by concurrent large-batch file uploads from multiple tenants. The OOM error caused the web server process to terminate and fail to recover on its own.

 

As an immediate fix, we updated the system configuration to automatically reboot on OOM errors and significantly increased the upload endpoint memory allocation. Stability was confirmed following load testing with large batches. In the next 3 weeks, we will address the architectural gap by extending load balancing and fault tolerance to the CMS upload path, bringing it in line with the rest of the Korbyt infrastructure.

Posted May 13, 2026 - 16:07 CDT

Resolved

This incident has been resolved.
Posted May 13, 2026 - 10:40 CDT

Monitoring

A fix has been implemented which should resolve this, we are continuing to monitor the uploads to ensure service is restored. An RCA will be provided by tomorrow EOB.
Posted May 13, 2026 - 09:41 CDT

Identified

We have identified the issue and are taking steps to keep service restored, in the meantime most uploads should still be succeeding.
Posted May 13, 2026 - 09:18 CDT

Investigating

We are seeing occasional errors when uploading files in the CMS, we are taking efforts to keep the service operational while we investigate the issue and will provide updates as we are able.
Posted May 13, 2026 - 08:41 CDT
This incident affected: Korbyt CMS.